I'm new to the FreeBSD release, but am very familiar with many Linux releases. I'm attempting to (1) keep my system updated, and (2) install new packages under FreeBSD 7.2. So is there an equivalent to the yum/yast/apt-get on the other Linux systems on FreeBSD? If so, what is it and how do I use it?
Thanks!
pkg_add -r or the ports tree :)
see:
http://www.freebsd.org/doc/en/books/handbook/packages-using.html
As others have said, there is no substitute for the handbook. In short what you're looking for is portupgrade. With it you can run commands like
Read the wiki page on portupgrade. And remember to ALWAYS read /usr/ports/UPDATING.
What you are looking for has two pieces. One is updating the base system, and the other is updating the additional packages.
The first can be done with
freebsd-update
. This command supports both updating with patches to the current release and upgrading to a new release. Look at its man page for details. It's far easier than installing updates from source.Updating packages also has two pieces -- updating the ports tree, and rebuilding out-of-date ports. The first can be done either with
cvs
/cvsup
/csup
or (my preference)portsnap
.portsnap
works a lot likefreebsd-update
but is for the ports tree. Again, see its man page. You can use eitherportupgrade
as described in another answer orportmaster
(which I prefer due to lower overhead and simplicity, although it probably doesn't have as many features asportupgrade
).The freeBSD handbook is your friend for updating...
FreeBSD actually has some very good documentation, since it's not forked into a bazillion distros like Linux is; their site has some really good central documentation for things.
This part talks about installing applications...
The handbook itself is a great place to get up to speed with using FreeBSD.