I'm currently running snv_129 (EON NAS image). I think I have somehow shorted one of my PHYs and I'm trying to debug the issue.
/etc/hostname.rge0 192.168.250.20 /etc/hostname.rge1 192.168.250.21
Router: 192.168.250.1 Network 192.168.250.0/24
I'm trying to switch the active/primary NIC from rge0 to rge1 and am unsure how to go about doing this (I really should have stayed with Linux, which I know a whole lot better).
Anyhow, netstat -rn gives me this:
Dest: default GW: 192.168.250.1 flags: UG
127.0.0.1 127.0.0.1
192.168.250.0 192.168.250.20 Interface: rge0
I cannot ping anything when using rge0 as the primary interface. I don't really have the skills with Solaris to know how to debug this issue.
svcs -a says everything is online, and I can ping 192.168.250.20 whether it's plugged in or not.
Any help would be appreciated, and I'm happy to add more information if necessary
EDIT:
My eventual goal was to do link aggregation. At this point, all I want is to return one of the two interfaces to functioning order - just one.
I've followed some of the advice below. Here is what I've done since last update:
Disable interface 1 in the BIOS. (only one interface detected)
dladm show-phys:
LINK: rge0 MEDIA: ethernet STATE: down SPEED: 1000 DUPLEX: full DEVICE: rge0
ifconfig rge0:
flags: UP BROADCAST MULTICAST IPv4 (RUNNING is not present) inet: 192.168.250.20 netmask ffffff00 broadcast 192.168.250.255 ether ff:7f:7f:7f:7f:7f
Anybody have any ideas on next steps?
I've never tried putting IPs into hostname.XX; typically the file has a hostname, and /etc/hosts maps the host name to the IP for that interface. Swap the hostnames listed in the per-interface files and reboot, and presto, swapped interfaces. (Or swap in /etc/hosts, but that could break more things.)
It's not clear what you are trying to achieve. If it's only testing basic IP connectivity with both interfaces I suggest you leave the standard system configuration aside and work with dladm/ifconfig directly.
Disable the SMF service so it doesn't interferer with your testing (svcadm disable physical:default)
Unplumb both interfaces (ifconfig rge0 unplumb; ifconfig rge1 unplumb)
Now configure rge0 and test it (ifconfig rge0 plumb; ifconfig rge0 192.168.250.20 netmask 255.255.255.0; ping your gateway). Remember to unplumb it after you determined it's working.
Now configure rge1 and test it (ifconfig rge0 plumb; ifconfig rge1 192.168.250.21 netmask 255.255.255.0; ping your gateway). Remember to unplumb it after you determined it's working.
Review the standard configuration (/etc/hostname.if /etc/defaultrouter /etc/netmasks) and re-enable the physical:default SMF service.
I don't think you can have two interfaces on the same subnet without some special routing or IPMP.
If you want both interfaces to work, you should enable ip multipathing (IPMP). Having two network physical interfaces in the same broadcast domain is unsupported and might lead to various issues with either Solaris or Linux, including the one you are experiencing.