I'm a Cisco newbie, have the 1841, with two ethernet interfaces:
interface FastEthernet0/0: Internal
Desired destination IP: 186.67.181.140
interface FastEthernet0/1: External World
IP 186.67.181.140
Want to make a HTTP port forwarding from External World to Internal IP.
Tried adding this rule, but does not make the forwarding:
ip nat inside source static tcp 192.168.1.20 80 186.67.181.140 80 extendable
Any idea why I don't get the port forwarding right?
Complete configuration:
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0 secondary
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 186.67.181.140 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 186.67.181.141
no ip http server
no ip http secure-server
ip nat inside source list 100 interface FastEthernet0/1 overload
ip nat inside source static tcp 192.168.1.20 80 186.67.181.140 80 extendable
!
!
access-list 100 permit ip any any
access-list 111 permit ip 192.168.1.0 0.0.0.255 any
access-list 111 permit ip 192.168.0.0 0.0.0.255 any
The problem was in my destination, different from cisco router.
To check if your cisco router is making port forwarding you do:
Then check if there is an entrance similar to this:
If it's there, it's making the port forwarding.