I'm running EIGRP (101 between r3,r4,r5 and all interfaces are added. Now I want r1 and r2 to reach to server 12.0.0.1 connected to r5. The server can't ping another PCs, but all PCs can ping 12.0.0.1. r3,r4,r5 are connected to the internet. I'm not redistributing.
This is the topology I have set up in my GNS3.
The RIP V2 protocol of Router R2 is recognizing and advertising the two networks that are advertised in EIGRP, even though the said information should only have been received through redistribution. How Do I ensure that RIP advertises only those subnets I want advertised and not all the subnets of that Classful network that may exist on that particular router?
The below is the Show Ip route and Show Running-config informations from the routers R2 and R3,
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.1.0/24 is variably subnetted, 5 subnets, 2 masks
C 192.168.1.64/28 is directly connected, Loopback1
R 192.168.1.32/28 [120/1] via 192.168.1.133, 00:00:00, Serial0/0
R 192.168.1.16/28 [120/1] via 192.168.1.133, 00:00:00, Serial0/0
R 192.168.1.128/30 [120/1] via 192.168.1.133, 00:00:00, Serial0/0
C 192.168.1.132/30 is directly connected, Serial0/0
R3#
//////////////////////////////////////////////////////////////////////////////
R3#sh run
Building configuration...
Current configuration : 1063 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 192.168.1.65 255.255.255.240
!
interface Serial0/0
ip address 192.168.1.134 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router rip
version 2
passive-interface default
network 192.168.1.0
neighbor 192.168.1.133
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R3#s
//////////////////////////////////////////////////////////////
R2#sh run
Building configuration...
Current configuration : 1240 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 192.168.1.17 255.255.255.240
!
interface Loopback2
ip address 192.168.1.33 255.255.255.240
!
interface Serial0/0
ip address 192.168.1.130 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial0/1
ip address 192.168.1.133 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router eigrp 10
network 192.168.1.16 0.0.0.15
network 192.168.1.128 0.0.0.3
no auto-summary
!
router rip
version 2
passive-interface default
network 192.168.1.0
neighbor 192.168.1.134
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
I understand that OSPF has states that describe the status of a neighbor (e.g. Init and Full). Does EIGRP also have similar information? I'm programmatically trying to get the status of an EIGRP neighbor using SNMP OIDs. Is there anything in the MIB that can give me the information that I need?
I am quite confusing with the Cisco IOS command.
what's the actual difference between redistribute static as i learn in EIGRP whereas default-information originate in RIP/RIPv2/OSPF?
I hope to get some answer over here as i can't find the difference from google neither cisco website.