I am trying to kill the redis-server
process on macOS. Whenever I kill it or shut it down, it restarts under a different process id.
I've tried killing it three ways:
redis-cli shutdown
sudo kill [proc-id]
: It's running asroot
for whatever reason, sosudo
is needed.brew services stop redis
I checked ~/Library/LaunchAgents/
and /System/Library/LaunchAgents/
for an applicable plist but none of the files contain redis
, case insensitive search.
I also checked the "Users & Groups" section of the macOS control panel and do not see any entries under "Login Items" that are applicable.
The macOS console app reveals something interesting when I kill the process:
com.apple.xpc.launchd[1] (org.redis.redis-server): Service only ran for 8 seconds. Pushing respawn out by 2 seconds`
So it seems that it's registered and being watchdogged by launchd, but I can't figure out where the configuration is for the life of me.
launchctl list|grep -i redis
does not reveal any results, either.
Thoughts?